
MODUL PRAKTIKUM 
ALGORITMA DAN PEMROGRAMAN 1 

 

 

 

 

 

 

Teks asli oleh Ferry Gustiawan, 
Diperbaharui untuk Mata Kuliah  

Praktikum Algoritma dan Pemrograman 1  
Fakultas Ilmu Komputer Universitas Sriwijaya 

Oleh Qurhanul Rizqie 

 

 

 

 
Laboratorium Dasar 

Fakultas Ilmu Komputer Universitas Sriwijaya 
2010/2011  



Ferry Gustiawan, refer to DR. Inggriani Liem & Sjukani  � Edited by Qurhanul Rizqie 1 

1. Pendahuluan 

 
Lingkungan Borland C++  Builder 6.0 

 

Turbo C++ 4.5 adalah tool yang dipakai untuk membuat code program dalam bahasa C ataupun C++. 

Berikut adalah jendela utama Borland C++ Builder 6.0. 

 

 
 

Create new, Open, Save, Save As File 

 

Untuk memulai membuat kode program di Borland C++ Builder 6.0 langkah-langkahnya adalah 

sebagai berikut : 

1. Buka Borland C++ Builder 6.0 dari menu program sehingga akan keluar jendela Borland C++ 

Builder 6.0 seperti gambar di atas. 

2. Secara default Borland C++ Builder 6.0, disediakan untuk membuat program berbasis GUI, 

namun dalam mata kuliah Praktikum Algoritma dan Pemrograman 1, kita hanya akan 

mempelajari cara membuat program berbasis konsol. Agar Borland C++ Builder 6.0, dapat 

digunakan untuk membuat program berbasis konsol pilih menu File > Close All untuk menutup 

seluruh project, kemudian pilih File > New > Other , maka akan tampil, jendela sebagai berikut : 
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3. Kemudian, pilihlah opsi Console Wizard, kemudan pada jendela yang muncul berikutnya, pilihlah 

opsi bahasa C, lalu klik OK. 

 

 

 

4. Tampilan jendela utama pada Borland C++ Builder 6.0, akan tampak sebagai berikut 
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5. Ketikkan kode pada jendela code sesuai sintaks bahasa C, apabila telah selesai kode yang telah 

diketikkan dapat disimpan sebagai file bahasa C dengan ekstensi ”*.c” dan projectnya akan 

disimpan dengan ekstensi ”*.bpr” 

6. Untuk menyimpan file pertama kali, pilih File > Save Project As, atur lokasi, dan beri nama 

sesuai keinginan.  

7. Untuk membuka file atau kode program yang sudah pernah dibuat,  pilih menu File > Open, pilih 

direktori yang diinginkan, kemudian pilih file dengan ekstensi ”*.c” atau ”*.bpr”  

 

 

Compile Program, Pendeteksian Error dan Warning, Run Program 

 

Setelah menuliskan kode program, maka berikutnya adalah compile program dengan tujuan untuk 

mendeteksi kesalahan-kesalahan dalam penulisan kode program. Adapun langkah-langkahnya 

adalah sebagai berikut : 

 

1. Pilih menu Project > Compile Unit, atau kombinasi tombol ALT+F9, akan tampil jendela status 

compile seperti berikut :  

 

 

 

 Dari status di atas maka tidak ditemukan error atau warning pada program. 

 

 

 

 Dari status di atas dapat dilihat bahwa terdapat error pada program. Untuk melihat pesan error 

tersebut klik OK maka akan pesan error akan tampil di bawah jendela code. 

2. Langkah berikutnya adalah membuat executable dari program, dengan cara pilih menu  Project 

> Create Project atau kombinasi tombol  Ctrl + F9 

3. Setelah kode program di-create maka langkah berikutnya adalah menjalankannya, yaitu dengan 

memilih menu Run > Run atau dengan tombol F9. 
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Program Pertama “Hello world” 

 

Langkah-langkah : 

1. Buka aplikasi Borland C++ Builder 6.0. 

2. Siapkan sebuah project console dengan cara yang telah diuraikan sebelumnya, kemudian 

ketikkan kode berikut : 

 

  
 

3. Simpan program tersebut dengan nama hello.c. 

4. Kompile program tersebut, lalu run. Akan tampil jendela hasil run program 

 

 

 

5. Simpan program tersebut. 

 

 

Catatan :  

Baris program ‘#include<conio.h>’ dan ‘getch()’ adalah baris yang ditambahkan agar hasil program dapat 

terlihat di layar, tanpa kedua baris program inipun program sudah dapat berjalan, namun agar hasilnya 

dapat dilihat, harus dibuka melalui Command Prompt. 

Contoh – contoh program selain program pertama ini tidak akan memasukkan kedua baris program 

tersebut, namun pada prakteknya, diharapkan mahasiswa untuk menambahkan sendiri baris program 

tersebut agar lebih mudah saat dilakukan evaluasi. 
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2. Tipe Dasar dan Bentukan 
 

Tipe data dapat dikelompokkan menjadi dua macam : 

1. Tipe Dasar 

2. Tipe Bentukkan 

 

Tipe Dasar 

Adalah tipe yang dapat langsung dipakai. 

Tipe Dasar Ukuran Memori  

(byte) 

Jangkauan Nilai Jumlah Digit 

Presisi 

char 1 -128 hingga +127 - 

int 2 -32768 hingga +32767 - 

long 4 
-2.147.438.648 hingga  

2.147.438.647 
- 

float 4 3,4E-38 hingga 3,4E38 6-7 

double 8 1.7E-308 hingga 1.7E308 15-16 

long double 10 3.4E-4932 hingga 1.1E4932 19 

 

        Tipe data dapat diubah ( type cast ), misalkan: 

           float x = 3.345; 

           int p = int(x);  

           maka nilai p adalah 3 (terjadi truncating). 

Tipe data yang berhubungan dengan bilangan bulat adalah char, int, long. Sedangkan lainnya 

berhubungan dengan bilangan pecahan. 

Contoh :  
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Output dari program adalah : 

19125 

 

Darimana angka 19125 ? 

Jika variable tidak diinisialisai, namun nilai keluarannya diminta, maka compiler dengan bijak akan 

menampilkan nilai acak yang nilainya tergantung dari jenis compilernya. 

 

Bilangan logika/Boolean 

Contoh : 

  

 

 

Bilangan bulat (Integer) 

 

Yang dimaksud dengan integer adalah bilangan bulat …-3,-2,-1, 0,1,2,3… 

Sebuah Integer N biasanya disajikan sebagai sebuah string di dalam memori komputer. 
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Beberapa format yang dipakai untuk mencetak nilai numerik integer : 

Kode Format Hasil yang dicetak 

%i atau %d 

%u 

%li 

%lu 

Numerik integer bertanda 

Numerik integer tak bertanda (unsigned integer) 

Numerik Long integer bertanda 

Numerik Unsigned Long Integerl 

%c Karakter ASCII 

%x 

%o 

Hexadecimal Integer 

Octal Integer 

 

 

Contoh 1 : 

 

 

 

Contoh 2 : 
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Bilangan riil 

 

Bilangan Riil adalah bilangan yang mengandung pecahan desimal, misalnya  3.65, 0.003 dan 

sebagainya. 

 

Contoh 1 : 

 

 
Contoh 2 : 

 

 
Contoh 3 : 

 
 

Karakter 

 

Contoh 1 : 
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Contoh 2 : 

 

 

String 

String adalah gabungan dari karakter. 

Contoh :  “ Belajar “  � Literal String 

      “ B “            � Karakter 

 

Contoh 1 : 

 

Contoh 2 : 

 
 

Contoh 3 : 
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Contoh 4 : 

 

Contoh 5 : 

 
Contoh 6 : 
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Enumerasi 

Enumerasi adalah daftar nilai konstanta integer. 

Contoh : 

 

 

 

 

Tipe Bentukan 

 

Tipe bentukan adalah type yang dibentuk dari type dasar atau dari type bentukan lain yang sudah 

didefinisikan, contohnya tipe struktur. Struktur terdiri dari data yang disebut field. Field–field 

tersebut digabungkan menjadi satu tujuan untuk kemudahan dalam operasi. 
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Bentuk umumnya : 

 

 tyedef struct{ tipe nama_field1;             

   tipe nama_field2; 

   tipe nama_field3; 

   . . . . 

            }nama_variabel;                                                                                                                                                                                             

 

 

Contoh : 
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3. Variabel 

 
Deklarasi variable 

 

Variable adalah suatu simbol atau lambang yang mempunyai nilai. Dalam pemrograman disebut 

juga area atau tempat di dalam memory komputer yang isinya bisa diubah-ubah. 

 

 

 

 

 

 

 

 

 Syarat penamaan variabel : 

1. Tidak boleh sama dengan nama atau kata yang sudah disiapkan oleh komputer (reserved 

word) seperti keyword dan functions. Juga harus berbeda dengan nama label atau konstanta 

yang dibuat oleh programmer. 

2. Maksimum 32 karakter, bila lebih 32 karakter maka karakter selebihnya tidak diperhatikan 

oleh komputer. Huruf besar dan huruf kecil berbeda. 

3. Karakter pertama harus huruf atau karakter garis bawah (underscore) dan karakter berikutnya 

boleh huruf atau angka atau karakter garis bawah. 

4. Tidak boleh ada spasi atau blank. 

 

Contoh penamaan variable yang benar : 

A, P5, Nilai, NILAI, nilai, HargaSatuan, Harga_Satuan, _Harga, dsb. 

  

 Bentuk umum deklarasi variable : 

  

 

 

Contoh : 

int x; // Deklarasi x bertipe integer 

char y, huruf, nim[10]; // Deklarasi variable bertipe char 

float nilai; // Deklarasi variable bertipe float 

double beta; // Deklarasi variable bertipe double 

Memori 

 

A B C 

Nama_tipe Nama_variable 
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int array[5][4]; // Deklarasi array bertipe integer 

Contoh : 

 

 

Variabel lokal 

 

Variable yang hanya bisa dipakai pada fungsi/prosedur itu sendiri. 

Contoh : 

 
 

Variabel A, B , dan T adalah variable lokal karena dideklarasikan di dalam prosedur dan hanya bisa 

dipakai oleh prosedur itu saja, yaitu prosedur main(). Pada program di atas akan terjadi error 

karena ada prosedur CETAK() yang menggunakan variable T dan variabel T  tidak dikenal oleh 

prosedur CETAK().  
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Variabel global 

 

Variabel yang bisa dipakai oleh fungsi/prosedur lain karena dideklarasikan secara global. 

 

Contoh : 

 

Dari program di atas dapat dilihat bahwa variable T adalah variabel global karena dideklarasikan di 

luar prosedur sehingga bisa dipakai oleh prosedur lain, yaitu prosedur CETAK().  Sedangkan 

variable A dan B adalah variabel lokal. 
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4. Nilai, Konstanta, Ekspresi, Input Ouput dan Operator 
 

 

Assignment  

Pemberian nilai atas suatu variabel disebut assignment.  

Contoh : 

int A; 

A = 5; 

 

Untuk lebih jelas perhatikan program perkalian dua bilangan berikut.  

 

 

 

Terdapat 3 buah assignment statement. 

 

Konstanta 

Perhatikan kembali program untuk mengalikan dua bilangan di bawah ini : 

 

 
a, b, dan c adalah nama variabel sedangkan 3 dan 5 adalah nilai konstanta numerik. 

Dalam bahasa C, konstanta dapat diberi nama. Lihat contoh berikut yang menghasilkan hasil yang 

sama dengan program di atas, dengan menggunakan define. 
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D adalah nama sebuah konstanta, nilai D tidak dapat dirubah.  

 

Cara lain dengan menggunakan const. 

 

 

 

 

Ekspresi 

Perhatikan assignment statement berikut ini : 

  

 X = A + B * C; 

 

A + B * C disebut arithmatic expression atau pernyataan aritmatika dimana A, B, dan C disebut 

operand (yang dioperasikan) sedangkan + dan * disebut arithmetic operator (operator 

aritmatika). 

 

Operator Aritmatika 

Dalam bahasa C dan C++ operator aritmatika yang digunakan (disusun berdasarkan tingkat hirarki 

tertinggi sampai dengan yang terendah) adalah sebagai berikut : 

 

Operator Maksud dan tingkat hirarki 

* dan / dan % Kali dan Bagi dan Modulus 
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* dan / dan % tingkt hirarkinya sama 

* dan / dan % tingkt hirarkinya lebih tinggi dari + dan - 

+ dan - Tambah dan Kurang 

+ dan – tingkat hirarkinya sama 

 

Pembagian  

Contoh 1 : 

int N = 25; 
N = N / 2; 
printf(“%i”, N); 
 

akan tercetak : 12 

 

Contoh 2 : 

float F = 25.0; 
F = F / 2; 
printf(“%f”, F); 
 

akan tercetak : 12.500000 

 

Contoh 3: 

int N; 
float F; 
N = 25; 
F = N / 2; 
printf (“%f”, F); 

 

Akan tercetak : 12.000000 

 

Contoh 4 : 

int N; 
float F; 
F = 25.5; 
N = F / 2; 
printf (“%i”, N); 

 

Akan tercetak : 12 

 

Modulus 
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Operator % biasa disebut Modulus, hanya berlaku untuk bilangan integer, sehingga % disebut sisa 

pembagian bilangan integer. 

Contoh   : 

int N = 25; 
int K; 
K = N % 2; 
printf (“%i”, K); 

 

Akan tercetak : 1 

 

Aritmatika dalam instruksi printf() 

Contoh  : 

int A = 25; 
printf(“%i”, A); 

 
printf(“%i”, A+1);  //Nilai A tidak berubah 
printf(“%i”, A+=1); //A ditambah 1 dulu baru diceta k 
printf(“%i”, A++);  //A dicetak dulu kemudian ditam bah 1 
printf(“%i”, ++A);  //A ditambah 1 dulu baru diceta k 
printf(“%i”, A--);  //A dicetak dulu kemudian dikur ang 1 
printf(“%i”, --A);  //A dikurang 1 dulu kemudian di cetak 

 
 

Pangkat 

Bahasa C, C++ tidak menyiapkan operator untuk pangkat tapi menyiapkan fungsi untuk perasi 

pangkat yang masuk dalam library file math.h. 

Contoh : 

 

 
 

 

Akar 

C atau C++ menyiapkan fungsi hanya untuk akar kwadrat yaitu sqrt(); 

 

Contoh : 
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Operator Relational 

Relational merupakan ungkapan dengan menghubungkan atau merelasikan dua buah nilai atau 

lebih tepatnya membandingkan dua buah nilai seperti dicontohkan berikut ini : 

 

a. 5 > 3  suatu pernyataan yang pasti bernilai TRUE 

b. N > 30 suatu pernyataan yang bisa bernilai TRUE dapat juga FALSE 

 

Operator relational  yang digunakan dalam bahasa C, C++ adalah : 

 

Operator Maksud 

== Sama dengan (Equal to) 

> Lebih besar dari (Greater than) 

< Lebih keci dari (Less than) 

>= Lebih besar atau sama dengan (Greater than or equal 

to) 

<= Lebih kecil atau sama dengan (Less than or equal to) 

!= Tidak sama dengan (Not equal to) 

 

Biasanya digunakan dalam oleh control statement if, or , atau while.  

Dalam bahasa C, suatu ungkapan yang menyatakan kondisi, bila bernilai TRUE maka secara 

numerik (binary) ungkapan tersebut bernilai 1(satu), sedangkan yang bernilai FALSE bernilai 0(nol). 

 

Contoh : 
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Pembacaan Nilai 

Instruksi untuk menginput data melalui keyboard pada program C dapat dibedakan menjadi dua 

macam : 

1. Instruksi input tanpa format, yaitu : 

gets (var) untuk karakter string 

var = getche() 

var = getchar() 

var = getch() 

 

instruksi ini hanya digunakan untuk menginput sebuah karakter dengan tipe char. 

 

Contoh 1 : 

 
 

Contoh 2 : 

 
 

2. Instruksi input menggunakan format.  

Instruksinya scanf(). 
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Contoh 1 : 

Input satu karakter 

 

 
 

Contoh 2 : 

Input dua karakter tanpa koma 

 

 

 

Contoh 3 : 

Input dua karakter disisipkan koma 

 

 

Contoh 4 : 
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Input dua karakter dipisah spasi 

 

 

Contoh 5 : 

Input berupa string 

 
 

Contoh  6 : 

Input berupa integer 
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5. Pernyataan Kondisi 

 
 

IF Statement 

 

Melakukan seleksi dapat dilakukan dengan control statement yaitu if dan switch. Berikut ini 

adalah contoh penggunaan if. 

 

5.1.1 Satu Kasus 

bentuk umum : 

 

 

 

 

 

 

 

Contoh : 

 
5.1.2 Lebih dari satu kasus 

bentuk umum : 

 

 

 

 

 

 

 

 

 

if (kondisi) 

    { 

Statement  

    } 

if (kondisi) 

    { 

Statement 1 

    } 

else 

   { 

 Statement 2 

   } 

 

if (kondisi 1) 

    { 

Statement 1 

    } 

else if (kondisi 2) 

   { 

 Statement 2 

   } 

else 

   { 

 Statement 3 

   } 
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Contoh 1 : 

 

 
 

Contoh 2 : 
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Switch Case 

 

Selain menggunakan if seleksi dapat juga menggunakan switch. 

Contoh : 
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6. Pengulangan (Looping) 

 
 

Pengulangan dalam bahasa C, C++ bisa menggunakan instruksi for, while dan do while. 

 

Pengulangan berdasarkan banyaknya pengulangan 

 

Contoh 1 : 

 

 

Contoh 2 : 

 

 

Contoh 3 : 
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Pengulangan berdasarkan kondisi berhenti  

Contoh  : 

 
 

Pengulangan berdasarkan kondisi pengulangan 

Contoh 1 : 
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Pengulangan berdasarkan 2 aksi 

Contoh : 
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7. Fungsi 
 

 

Fungsi adalah sejumlah instruksi yang dikelompokkan menjadi satu, berdiri sendiri, yang berfungsi 

untuk menyelesaikan suatu pekerjaan. Bahasa C minimal mempunyai satu buah fungsi yang 

disebut Fungsi main() yaitu fungsi induk/utama. 

 

Contoh : 

 

 

Dari contoh di atas fungsi HITUNG adalah fungsi yang dibuat sendiri. Fungsi HITUNG dipanggil di 

main. Fungsi yang kita buat sendiri bisa diletakkan diatas atau pun di bawah main. Bila fungsi yang 

kita buat diletakkan di atas main maka tidak perlu dideklarasikan lagi. 
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8. Prosedur 

 

 
Prosedur sama dengan fungsi hanya saja tidak mengembalikan nilai return. 

Contoh : 
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9. Array 

 

 
Array satu dimensi 

 

Dalam bahasa pemrograman, array adalah variabel yang sejenis yang berderet sedemikian rupa 

sehingga alamatnya saling bersambung/kontigu atau dengan kata lain variabel berindeks. 

 

Bentuk umum : 

 

  
Ilustrasi array satu dimensi : 

 

 

Array di atas mempunyai enam element. 

 

Contoh 1 : 

 

 
 

int A[5] artinya menyiapkan array satu dimensi bertipe int dengan 5 elemen yang diberi index dari 

0 sampai dengan 4.  Program di atas akan mengalokasi 5 alamat elemen array dan mencetak 

alamat array dalam hexadesimal. 

Ilustrasinya :   

             0       1       2      3        4 

 

 

Contoh 2 : 

A 

tipe_array nama_array  
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Menyiapkan array numeric dengan nilainya. 

 

 

 

Akan tercetak : 3 5 12 7 9 

 

Contoh 3 : 

 
 

Akan tercetak : 3 5 0 0 0 

 

 

 

 

 

 

 

 

 

 

 

 

Contoh 4 : 
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Akan tercetak : ABC 

 

 

Array Multidimensi 

 

Array multidimensi adalah array yang mempunyai lebih dari satu dimensi.  Misal : A[3][5] artinya 

array tersebut mempunyai 3 baris 5 kolom. 

 

Contoh 1 : 

 

 

 

Contoh 2 : 
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